The Film & TV Script Editor

Overview

In Celtx, the moment you open a script file it's ready to go. No adjusting margins or setting up tab points; no need to worry about capitalization. Just type, enter, and move on...

 

Navigation

When you first open your project you will notice a menu on the left:

This menu will help you navigate your project. From adding new collaborators under the Team option to accessing the Beat Sheet, Catalog, etc. If you would like to open the Breakdown or Shot List this will be on the right menu of the script instead. 

If you were a previous user of the script editor you may have added some extra scripts or files under the older Additional File option. You can still find these files, under File & Media option at the bottom and then clicking on File. 

 

Formatting

The TAB key will switch the element setting of your current line. In a screenplay, each line of text or paragraph can be classified as one type of element. Those elements all have a distinct placement, letter case, and margins.

When you are writing, our system will try to intelligently guess at what you're going to write next. So if you're writing a character name, and hit ENTER, the system will automatically switch to a dialog element.

You can also use the Element Selection menu in the toolbar to change your current element type. Below is an example of what the various elements look like.

Formatting.png

Learn more about the different types of Elements and how to use them in our Writing Resources section.

Dual Dialogue

Accessible via the Element Selection menu. When two characters are speaking simultaneously our system will place the text side by side. Type the text as normal, then highlight both sets and hit this icon to display the text side by side.

DD.png

 

The Toolbar

Show/Hide scene navigation  

Use this option to enable the scene navigator from within your editor, making it easy to move (and move between scenes) in your script. 

Element Selection menu

You can use this menu to change the element type of the paragraph you're editing.

 

The File Menu 

The first menu in the top toolbar contains common actions which you can do with the script, whether starting out or submitting. 

Import Script

This menu item will allow you to import and append text from other documents on your computer. It accepts .pdf, .doc, .docx, .rtf, .txt, .fdx, .html, .cxscript and .celtx files

Read more about importing

Export to Script

These options allow you to export your entire script content to a .txt or .fountain file for use in other programs.

Add Episodes

If your subscription supports episodic projects, here is where you can add an episodes to an existing episodic script, or change a single project script to an episodic one. 

Rename Script

Change the name on the script file itself. 

Create Link

This option will generate a public, read-only link that you can share with other people via email or social media. Anyone with the shareable link will have access to read and print your script in its most recent version.

Create Sides

This will activate the sides wizard, which will walk you through creating sides from select scenes from your script.

Read more about Sides

Request Approval

Request approval from peers and other users (even from outside Celtx).

Read more about Approvals

History

This selection will allow you to view and optionally restore your script to previous versions (part of a paid subscription)

Read more about Script History

Print / Download

This will open the print preview menu, where you can add watermarks to your pages and choose what content you want included in your printout.

Read more about printing

Save Draft

This option will allow users to create a new version of their main project script, should you with to take your script in a potentially new direction. Read more about Drafts here.

Read more about Drafts

 

The Edit Menu

Screenshot 2024-04-19 at 4.57.04 PM.png

The Edit Menu choices will allow you to change large selection of how the scripts look

Line Format

This powerful option lets you quickly apply Bold/Italics/Underline to entire text types; action, dialog, character names, etc... Once you apply formatting to a paragraph/line (bolding for instance to action), placing your cursor and choosing "Edit, Line Formatting, update action style" will apply bolding to each action instance in your script, and any further action sequences added. 

The "Reset Style" will clear/reset any custom formatting you had applied to that text type. 

Please note: This will overwrite any current formatting currently applied for words in a paragraph with that text type. 

Scene Numbers

Clicking on a scene number in your script will allow you to enter a custom number:

In the Edit menu you can select whether you want to see your custom numbers or the original ones in your script and rest of your project documents (breakdown, schedule, etc).

Here you can also lock scene numbers so that these can no longer be edited.

Undo/Redo (Ctrl+Z, Ctrl+Shift+Z)

Also located on the toolbar, these options will allow you to undo and redo recent changes to your text.

Format

The Format sub-menu options: Bold, ItalicsUnderline, UPPERCASE and lowercase options. Please note the shortcuts, which help keep your hands on the keyboard. 

Title Page

This option lets you choose from the three different title page layouts; Default, Centered Image, and Image Only.

You can include the title page when you print your script.

Read more about Title pages

Cut, Copy & Paste (Ctrl+X, Ctrl+C, Ctrl+V)

These options allow users to move selections of text to a different location in the script, or to a new script all together.

Find/Replace (Ctrl+F)

Choosing this option will open up the find/replace toolbar, allowing you to search the text of your script for words or phrases, and replace them. You can use Ctrl+F as well. 

FindReplace.png

Check Spelling (Ctrl+Alt+S)

This will start our built-in spellchecker. It will go line by line, highlight issues, and make suggestions to fix spelling issues in your script.

Revision Mode/Reset Revisions

This button activates Revision mode, which locks scene numbers, highlights text changes, and more.

Read more about Revision mode

Headers and Footers

This opens the Headers and Footers settings for your script. By default, basic users will see the text "Created Using Celtx" in their footer.

The feature allows you to add/remove/edit custom text, page numbers, the current date, and more to the top and bottom of the page.

mceclip13.png

Script Settings

The script settings window allows you to customize the page numbers, paper size, and other page settings.

settings_2019.png

FYI: Page numbering starts on page 2 as per industry script standards, and line spacing is 51/53 (US Letter) and 56/58 (A4) for normal and tight, respectively. 

 

The View Menu

The View menu has options for how the editor itself, looks.

Tools

Use this option to pick and choose from utilities you'd like displayed on your righthand sidebar  (the tool pallet).  There is also an option to quickly select or deselect all items. 

Show/Hide Readthrough

This option will toggle the Readthrough option visibility on the Right hand Sidebar, and is available for main project scripts.

Comments

File-specific comments added by yourself and collaborators will be displayed via this menu item.  

Scene Numbering

This selection allows you to add numbers to your scene headings. You can set it to left, right, both sides, or none.

firefox_tKYAzreAJo.png

Zoom

Set your editor's zoom level. Zoom level can also be set via the toolbar.

mceclip8.png

Night Mode 

This will darken your editor, and invert the text/background colors to ease eye strain.

NightMode.png

Color

You can customize the text and page color of your script. The top color is the text color, and is black by default. The bottom one is the page color, and is white by default.

Note: This is meant as a viewing option, and will not be included in your printed/pdf scripts.

 

Help

You might have guessed it, at some point you may refer to our outside resources to get past a hurdle. We'll be here!

Tour

Each project file will have a Tour button available. These guided demos will help get you started, and serve as a quick refresher, if needed.

Help Center

Choose this option to load the Help Center in a new browser tab.

Keyboard Shortcuts

Displays the list of Keyboard shortcuts. Your hands will never have to leave the keys again. Here the article

Blog

Here's the link to blog site. Our writers keep this up to date with all things Celtx.

Live Support

If you're subscribed to a plan which includes Live support, choosing this option will surface the chat window itself. 

 

The Righthand Sidebar

The righthand sidebar contains several sections to access additional Celtx tools. Each tool can be opened by clicking on the menu item, and closed by hitting the Screen_Shot_2018-09-13_at_3.38.14_PM.png that appears in the toolbar.

Comments

This allows you to collaborate with your colleagues and add script-anchored feedback to your script.

You can also @mention other users shared on your projects.

Read more about Comments

Media

This allows you to add images to your project and associate it directly with the text of your script.

Read more about Media

Breakdown

This allows you to begin breaking down your script by tagging elements such as props, wardrobe, VFX and more directly in your script text.

Read more about Breakdown

Shot List

This will let you tag your script with shots, and build a shotlist for your director and camera team to follow during your shoot.

Read more about Shot Lists

Read Through

This sidebar lets you hear your story play out from any line at any time with fully customizable text-to-speech playback.
*NOTE* If you don't see Read Through, you may need to toggle this feature on from the 'View' menu > 'Tools'

 

The footer of your editor includes:

Insights timers and tools

The insights timers on the bottom left will tell you how long you've been typing in this session, and how long you've had your script open but inactive.

Clicking on the Insights link will give you a stats window where you can set goals, track your progress, and more.

Learn more about Insights

Last saved

At the bottom right of your page is a running page and word count, as well as the when the last save of your script happened.

 

 

Collaboration

Finally, when more than one user has the document open at once, the header will display their avatars in the upper right of your screen to let you know. 

Learn more about Collaboration

 

Have more questions? Submit a request